MediaPlayer/plugin.py: use correct InfoBarSubtitleSupport instance for Subtitle screen
[enigma2.git] / lib / python / Plugins / Extensions / MediaPlayer / plugin.py
index 71b486a..42800b5 100644 (file)
@@ -901,7 +901,7 @@ class MediaPlayer(Screen, InfoBarBase, InfoBarSeek, InfoBarAudioSelection, InfoB
                
        def subtitleSelection(self):
                from Screens.Subtitles import Subtitles
-               self.session.open(Subtitles)
+               self.session.open(Subtitles, self)
        
        def hotplugCB(self, dev, media_state):
                if dev == harddiskmanager.getCD():