Use apt to install oauth dependency, not pecl
authorChristian Weiske <cweiske@cweiske.de>
Wed, 17 Jan 2018 20:56:12 +0000 (21:56 +0100)
committerChristian Weiske <cweiske@cweiske.de>
Wed, 17 Jan 2018 20:56:12 +0000 (21:56 +0100)
Resolves: https://github.com/cweiske/grauphel/issues/44

README.rst

index 483f4ed..d03e18e 100644 (file)
@@ -129,11 +129,10 @@ It may be that grauphel now shows you an error message::
   PHP extension "oauth" is required
 
 You have to install the PHP PECL oauth extension now.
-On Debian 7, do the following::
+On Debian 7 or higher, do the following::
 
-  $ apt-get install libpcre3-dev php-pear php5-dev
-  $ pecl install oauth-1.2.3
-  $ echo 'extension=oauth.so' > /etc/php5/conf.d/oauth.ini
+  $ apt install php-oauth
+  $ php5enmod oauth
   $ /etc/init.d/apache2 restart
 
 Reload the nextCloud page in your browser now.