rename "secureAtLevel" variable since it does not define a level at all
[phorkie.git] / www / list.php
1 <?php
2 /**
3  * List a repository
4  */
5 namespace phorkie;
6 $reqWritePermissions = false;
7 require_once 'www-header.php';
8 $rs = new Repositories();
9
10 $page = 0;
11 if (isset($_GET['page'])) {
12     if (!is_numeric($_GET['page'])) {
13         throw new Exception_Input('List page is not numeric');
14     }
15     $page = (int)$_GET['page'] - 1;
16 }
17
18 $perPage = 10;
19 list($repos, $repoCount) = $rs->getList($page, $perPage);
20
21 $pager = new Html_Pager(
22     $repoCount, $perPage, $page + 1, '/list/%d'
23 );
24
25 render(
26     'list',
27     array(
28         'repos' => $repos,
29         'pager' => $pager,
30     )
31 );
32 ?>