warn about non-configured search adapter during indexing
[phorkie.git] / data / config.default.php
index 8f796f4..5b56fc7 100644 (file)
@@ -1,10 +1,24 @@
 <?php
+$pharFile = \Phar::running();
+if ($pharFile == '') {
+    $phorkieDir = __DIR__ . '/../';
+    $wwwDir = $phorkieDir . 'www/';
+} else {
+    //remove phar:// from the path
+    $phorkieDir = dirname(substr($pharFile, 7)) . '/';
+    $wwwDir = $phorkieDir;
+}
+
 $GLOBALS['phorkie']['cfg'] = array(
     'debug'         => false,
-    'gitdir'        => __DIR__ . '/../repos/git/',
-    'workdir'       => __DIR__ . '/../repos/work/',
+    'git'           => array(
+        'public'    => '%BASEURL%' . 'repos/git/',
+        'private'   => null,
+    ),
+    'gitdir'        => $wwwDir . 'repos/git/',
+    'workdir'       => $wwwDir . 'repos/work/',
     'tpl'           => __DIR__ . '/templates/',
-    'baseurl'       => '/',
+    'baseurl'       => null,
     'avatars'       => true,
     'css'           => '',
     'iconpng'       => '',//phorkie browser icon (favicon)
@@ -12,7 +26,6 @@ $GLOBALS['phorkie']['cfg'] = array(
     'topbar'        => '',
     'setupcheck'    => true,
     'elasticsearch' => null,
-    'geshi'         => 'MediaWiki/geshi/geshi/geshi.php',
     'index'         => 'new',//"new" or "list"
     'perPage'       => 10,
     'defaultListPage' => 'last',//a number or "last"